const regex = /.*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*HbbTV\\\/1\\.4\\.1(\\s|\\t)\\((.*);(\\s|\\t)(.*);(\\s|\\t)(.*);(\\s|\\t)(.*);(\\s|\\t)(.*);\\)', '')
const str = `Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}