using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)";
string input = @"Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}