import Foundation
let pattern = #"(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"jj.jj@domain.com"
"hello@myemailadd.com.uk "
"HELLO@MYNAME.COM"
"japan@water.com.uk.uk.uk"
"me.me.me@domain.com.uk.uk"
"hello99@khalsa-aid.com"
"hello.me@myemailadd.com.in"
"hello.me@tax.gov.uk"
"my_name@council.co.uk"
"my-hello@bye-bye.co.uk"
"hello@my-99GOALS.co9.uk"
"Hello_Hello@two.com"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)