// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)").unwrap();
let string = "
\"jj.jj@domain.com\"
\"hello@myemailadd.com.uk \"
\"HELLO@MYNAME.COM\"
\"japan@water.com.uk.uk.uk\"
\"me.me.me@domain.com.uk.uk\"
\"hello99@khalsa-aid.com\"
\"hello.me@myemailadd.com.in\"
\"hello.me@tax.gov.uk\"
\"my_name@council.co.uk\"
\"my-hello@bye-bye.co.uk\"
\"hello@my-99GOALS.co9.uk\"
\"Hello_Hello@two.com\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}