# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)"
test_str = ("\n\n"
"\"jj.jj@domain.com\"\n"
"\"hello@myemailadd.com.uk \"\n"
"\"HELLO@MYNAME.COM\"\n"
"\"japan@water.com.uk.uk.uk\"\n"
"\"me.me.me@domain.com.uk.uk\"\n"
"\"hello99@khalsa-aid.com\"\n"
"\"hello.me@myemailadd.com.in\"\n"
"\"hello.me@tax.gov.uk\" \n"
"\"my_name@council.co.uk\" \n\n"
"\"my-hello@bye-bye.co.uk\"\n"
"\"hello@my-99GOALS.co9.uk\"\n\n"
"\"Hello_Hello@two.com\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.