// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(x+x+)+y").unwrap();
let string = "
xxxxxxxxxxxxxxxx
Catastrophic backtracking example:
Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.
With just 16 'x' it already takes a large amount of steps to finally decides it does not work.
(click \"regex debugger\" on the left to see details on steps taken)
See https://www.regular-expressions.info/catastrophic.html for more info.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}