using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(x+x+)+y";
string input = @"
xxxxxxxxxxxxxxxx
Catastrophic backtracking example:
Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.
With just 16 'x' it already takes a large amount of steps to finally decides it does not work.
(click ""regex debugger"" on the left to see details on steps taken)
See https://www.regular-expressions.info/catastrophic.html for more info.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}