#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(x+x+)+y"
Local $sString = "" & @CRLF & _
"xxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"Catastrophic backtracking example:" & @CRLF & _
"" & @CRLF & _
"Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match." & @CRLF & _
"With just 16 'x' it already takes a large amount of steps to finally decides it does not work." & @CRLF & _
"" & @CRLF & _
"(click "regex debugger" on the left to see details on steps taken)" & @CRLF & _
"" & @CRLF & _
"See https://www.regular-expressions.info/catastrophic.html for more info."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")