re = /on\w+\s?=\s?+("|')?[^"'>]*("|')?(?=>)/
str = '<buttn onclick ="> onclick = alert(bob)>fds</buttn>dsadsadsa<p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end