$re = '/on\w+\s?=\s?+("|\')?[^"\'>]*("|\')?(?=>)/';
$str = '<buttn onclick ="> onclick = alert(bob)>fds</buttn>dsadsadsa<p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);