using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"on\w+\s?=\s?+(""|')?[^""'>]*(""|')?(?=>)";
string input = @"<buttn onclick =""> onclick = alert(bob)>fds</buttn>dsadsadsa<p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}