import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[hH][tT]{2}[pP][sS]{0,1}:\\/\\/)?[wW]{0,3}\\.{0,1}[yY][oO][uU][tT][uU](?:\\.[bB][eE]|[bB][eE]\\.[cC][oO][mM])?\\/(?:(?:[wW][aA][tT][cC][hH])?(?:\\/)?\\?(?:.*)?[vV]=([a-zA-Z0-9--]+).*|([A-Za-z0-9--]+))";
final String string = "www.youtube.com/watch?v=fjgfjgk";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}