package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[hH][tT]{2}[pP][sS]{0,1}:\/\/)?[wW]{0,3}\.{0,1}[yY][oO][uU][tT][uU](?:\.[bB][eE]|[bB][eE]\.[cC][oO][mM])?\/(?:(?:[wW][aA][tT][cC][hH])?(?:\/)?\?(?:.*)?[vV]=([a-zA-Z0-9--]+).*|([A-Za-z0-9--]+))`)
var str = `www.youtube.com/watch?v=fjgfjgk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}