import Foundation
let pattern = #"((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2 x * 3 y * + 3 x * + 4 y * + 3 x * +"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3 $2 $6 + * $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)