$re = '/((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))/';
$str = '2 x * 3 y * + 3 x * + 4 y * + 3 x * +';
$subst = "$3 $2 $6 + * $4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;