const regex = /((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+\\.?\\d*) ([a-zA-Z]) \\*)(.*?)(((\\d+\\.?\\d*) \\3 \\*))', 'g')
const str = `2 x * 3 y * + 3 x * + 4 y * + 3 x * +`;
const subst = `$3 $2 $6 + * $4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);