import Foundation
let pattern = #",([^,]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript
DailyStats,jlaer;priatil;uido,DailyStatsAdm
AuditEvents,aorl;atil;le;mran;uido,AuditEventsAdm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)