use strict;
my $str = 'http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript
DailyStats,jlaer;priatil;uido,DailyStatsAdm
AuditEvents,aorl;atil;le;mran;uido,AuditEventsAdm
';
my $regex = qr/,([^,]*)$/mp;
my $subst = ';$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";