const regex = /(\d{11})|0x\d{1}([0-9a-fA-F]{8})\:?|\s+?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{11})|0x\\d{1}([0-9a-fA-F]{8})\\:?|\\s+?', '')
const str = `ESN:0x0106C01B8 4141
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}