using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{11})|0x\d{1}([0-9a-fA-F]{8})\:?|\s+?";
string input = @"ESN:0x0106C01B8 4141
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}