package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{11})|0x\d{1}([0-9a-fA-F]{8})\:?|\s+?`)
var str = `ESN:0x0106C01B8 4141
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}