import Foundation
let pattern = #"\s+([a-zA-Z-]+)=([a-zA-Z0-9-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p class=MsoNormal align=center style='text-align:center'><b><span
style='font-size:24.0pt;font-family:Calibri;color:maroon'>Electronic
Subscriptions</span></b></p>
<table class=MsoNormalTable border=0 cellpadding=0 align=left width="100%"
style='width:100.0%;mso-cellspacing:1.5pt;background:white;mso-table-lspace:
9.0pt;margin-left:6.75pt;mso-table-rspace:9.0pt;margin-right:6.75pt;
mso-table-anchor-vertical:paragraph;mso-table-anchor-horizontal:column;
mso-table-left:left;mso-padding-alt:0in 0in 0in 0in'>
<tr style='mso-yfti-irow:0;mso-yfti-firstrow:yes;mso-yfti-lastrow:yes;
height:662.25pt'>
<td valign=top style='padding:15.0pt 15.0pt 15.0pt 15.0pt;height:662.25pt'>
<p class=MsoNormal style='mso-element:frame;mso-element-frame-hspace:9.0pt;
mso-element-wrap:around;mso-element-anchor-vertical:paragraph;mso-element-anchor-horizontal:
column;mso-height-rule:exactly'><span style='font-size:11.0pt;font-family:
Calibri;color:black'> </span></p>
<p class=MsoNormal style='mso-element:frame;mso-element-frame-hspace:9.0pt;
mso-element-wrap:around;mso-element-anchor-vertical:paragraph;mso-element-anchor-horizontal:
column;mso-height-rule:exactly'><span style='font-size:11.0pt;font-family:
Calibri;color:black'>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1="\2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)