// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s+([a-zA-Z-]+)=([a-zA-Z0-9-]+)").unwrap();
let string = "<p class=MsoNormal align=center style='text-align:center'><b><span
style='font-size:24.0pt;font-family:Calibri;color:maroon'>Electronic
Subscriptions</span></b></p>
<table class=MsoNormalTable border=0 cellpadding=0 align=left width=\"100%\"
style='width:100.0%;mso-cellspacing:1.5pt;background:white;mso-table-lspace:
9.0pt;margin-left:6.75pt;mso-table-rspace:9.0pt;margin-right:6.75pt;
mso-table-anchor-vertical:paragraph;mso-table-anchor-horizontal:column;
mso-table-left:left;mso-padding-alt:0in 0in 0in 0in'>
<tr style='mso-yfti-irow:0;mso-yfti-firstrow:yes;mso-yfti-lastrow:yes;
height:662.25pt'>
<td valign=top style='padding:15.0pt 15.0pt 15.0pt 15.0pt;height:662.25pt'>
<p class=MsoNormal style='mso-element:frame;mso-element-frame-hspace:9.0pt;
mso-element-wrap:around;mso-element-anchor-vertical:paragraph;mso-element-anchor-horizontal:
column;mso-height-rule:exactly'><span style='font-size:11.0pt;font-family:
Calibri;color:black'> </span></p>
<p class=MsoNormal style='mso-element:frame;mso-element-frame-hspace:9.0pt;
mso-element-wrap:around;mso-element-anchor-vertical:paragraph;mso-element-anchor-horizontal:
column;mso-height-rule:exactly'><span style='font-size:11.0pt;font-family:
Calibri;color:black'>";
let substitution = " \\1=\"\\2\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}