use strict;
my $str = 'A1/EXT "BSCMAT2_G12BIPA" 392 190602 1837
RADIO X-CEIVER ADMINISTRATION
BTS EXTERNAL FAULT
MO RSITE CLASS
RXOCF-181 SNMAIPIRE 1
EXTERNAL ALARM
ALTA_TEMPERATURA_CF_GSM
MENOR CF_GSM
MAYOR CF_GSM
DESCARGA_DE_BATERIAS_CF_GSM
FALLA_DE_AC_EXTERNO
A1/EXT "BSCMAT2_G12BIPA" 580 190619 1320
RADIO X-CEIVER ADMINISTRATION
BTS EXTERNAL FAULT
MO RSITE CLASS
RXOCF-244 LEZAMA 1
EXTERNAL ALARM
ALTA TEMPERATURA CF_GSM
MENOR CF_GSM
MAYOR CF_GSM
DESCARGA DE BATERIAS CF_GSM
FALLA DE AC EXTERNO
TRANSFER ACTIVO
MOTOGENERADOR ENCENDIDO
FALLA DE MOTOGENERADOR
BAJO NIVEL DE COMBUSTIBLE
';
my $regex = qr/(?:A1/EXT \"\w*\" \d+ (\d+)\s+(\d+)(?:[\w\s\-]+)CLASS(?:\s+[\w-]+)\s+(\w+)(?:[\w\s\-]+)EXTERNAL ALARM)|([\w]+$|[\w]+\s[\w]+$|[\w]+\s[\w]+\s[\w]+$|[\w]+\s[\w]+\s[\w]+\s[\w]+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}