#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:A1/EXT \"\w*\" \d+ (\d+)\s+(\d+)(?:[\w\s\-]+)CLASS(?:\s+[\w-]+)\s+(\w+)(?:[\w\s\-]+)EXTERNAL ALARM)|([\w]+$|[\w]+\s[\w]+$|[\w]+\s[\w]+\s[\w]+$|[\w]+\s[\w]+\s[\w]+\s[\w]+$)"
Local $sString = "A1/EXT "BSCMAT2_G12BIPA" 392 190602 1837" & @CRLF & _
"RADIO X-CEIVER ADMINISTRATION" & @CRLF & _
"BTS EXTERNAL FAULT" & @CRLF & _
"" & @CRLF & _
"MO RSITE CLASS" & @CRLF & _
"RXOCF-181 SNMAIPIRE 1" & @CRLF & _
"" & @CRLF & _
"EXTERNAL ALARM" & @CRLF & _
"ALTA_TEMPERATURA_CF_GSM" & @CRLF & _
"MENOR CF_GSM" & @CRLF & _
"MAYOR CF_GSM" & @CRLF & _
"DESCARGA_DE_BATERIAS_CF_GSM" & @CRLF & _
"FALLA_DE_AC_EXTERNO" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"A1/EXT "BSCMAT2_G12BIPA" 580 190619 1320" & @CRLF & _
"RADIO X-CEIVER ADMINISTRATION" & @CRLF & _
"BTS EXTERNAL FAULT" & @CRLF & _
"" & @CRLF & _
"MO RSITE CLASS" & @CRLF & _
"RXOCF-244 LEZAMA 1" & @CRLF & _
"" & @CRLF & _
"EXTERNAL ALARM" & @CRLF & _
"ALTA TEMPERATURA CF_GSM" & @CRLF & _
"MENOR CF_GSM" & @CRLF & _
"MAYOR CF_GSM" & @CRLF & _
"DESCARGA DE BATERIAS CF_GSM" & @CRLF & _
"FALLA DE AC EXTERNO" & @CRLF & _
" TRANSFER ACTIVO" & @CRLF & _
"MOTOGENERADOR ENCENDIDO" & @CRLF & _
"FALLA DE MOTOGENERADOR" & @CRLF & _
"BAJO NIVEL DE COMBUSTIBLE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")