import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:A1/EXT \\\"\\w*\\\" \\d+ (\\d+)\\s+(\\d+)(?:[\\w\\s\\-]+)CLASS(?:\\s+[\\w-]+)\\s+(\\w+)(?:[\\w\\s\\-]+)EXTERNAL ALARM)|([\\w]+$|[\\w]+\\s[\\w]+$|[\\w]+\\s[\\w]+\\s[\\w]+$|[\\w]+\\s[\\w]+\\s[\\w]+\\s[\\w]+$)";
final String string = "A1/EXT \"BSCMAT2_G12BIPA\" 392 190602 1837\n"
+ "RADIO X-CEIVER ADMINISTRATION\n"
+ "BTS EXTERNAL FAULT\n\n"
+ "MO RSITE CLASS\n"
+ "RXOCF-181 SNMAIPIRE 1\n\n"
+ "EXTERNAL ALARM\n"
+ "ALTA_TEMPERATURA_CF_GSM\n"
+ "MENOR CF_GSM\n"
+ "MAYOR CF_GSM\n"
+ "DESCARGA_DE_BATERIAS_CF_GSM\n"
+ "FALLA_DE_AC_EXTERNO\n\n\n\n"
+ "A1/EXT \"BSCMAT2_G12BIPA\" 580 190619 1320\n"
+ "RADIO X-CEIVER ADMINISTRATION\n"
+ "BTS EXTERNAL FAULT\n\n"
+ "MO RSITE CLASS\n"
+ "RXOCF-244 LEZAMA 1\n\n"
+ "EXTERNAL ALARM\n"
+ "ALTA TEMPERATURA CF_GSM\n"
+ "MENOR CF_GSM\n"
+ "MAYOR CF_GSM\n"
+ "DESCARGA DE BATERIAS CF_GSM\n"
+ "FALLA DE AC EXTERNO\n"
+ " TRANSFER ACTIVO\n"
+ "MOTOGENERADOR ENCENDIDO\n"
+ "FALLA DE MOTOGENERADOR\n"
+ "BAJO NIVEL DE COMBUSTIBLE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}