re = /^(([A-Za-z]{3,9}:(\/\/))([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+))(?:([.-;:&=\+\$,\w\/]*))$/m
str = 'https://blo23423423---4234g3.asd23423423asdas.uk.com/sdfs.com/first.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end