const regex = /^(([A-Za-z]{3,9}:(\/\/))([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+))(?:([.-;:&=\+\$,\w\/]*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-Za-z]{3,9}:(\\\/\\\/))([-;:&=\\+\\$,\\w]+)[.]([-;:&=\\+\\$,\\w]+)[.]([-;:&=\\+\\$,\\w]+))(?:([.-;:&=\\+\\$,\\w\\\/]*))$', 'gm')
const str = `https://blo23423423---4234g3.asd23423423asdas.uk.com/sdfs.com/first.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}