import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Za-z]{3,9}:(\\/\\/))([-;:&=\\+\\$,\\w]+)[.]([-;:&=\\+\\$,\\w]+)[.]([-;:&=\\+\\$,\\w]+))(?:([.-;:&=\\+\\$,\\w\\/]*))$";
final String string = "https://blo23423423---4234g3.asd23423423asdas.uk.com/sdfs.com/first.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}