re = /[\w\s<>]*(?![\w\s<>]*"+.*"+)(trekking)/m
str = 'attribute="abc trekking abc" abc trekking, \'abc trekking "abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end