using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\s<>]*(?![\w\s<>]*""+.*""+)(trekking)";
string input = @"attribute=""abc trekking abc"" abc trekking, 'abc trekking ""abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}