$re = '/[\w\s<>]*(?![\w\s<>]*"+.*"+)(trekking)/m';
$str = 'attribute="abc trekking abc" abc trekking, \'abc trekking "abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);