import Foundation
let pattern = #"^((http:\/\/)?(((([\w\d]|[\w\d][\w\d\-]*[\w\d])\.)*((\w|\w[\w\d\-]*[\w\d]))*(\:\d+)+?)(\/[\w\;\:\@\&\=]*[\/[\w\;\:\@\&\=]*]*(\?[\w\;\:\@\&\=]*)?)))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
www.google.gmail.com:32/fsd?adsf=asdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}