import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http:\\/\\/)?(((([\\w\\d]|[\\w\\d][\\w\\d\\-]*[\\w\\d])\\.)*((\\w|\\w[\\w\\d\\-]*[\\w\\d]))*(\\:\\d+)+?)(\\/[\\w\\;\\:\\@\\&\\=]*[\\/[\\w\\;\\:\\@\\&\\=]*]*(\\?[\\w\\;\\:\\@\\&\\=]*)?)))$";
final String string = "www.google.gmail.com:32/fsd?adsf=asdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}