$re = '/^((http:\/\/)?(((([\w\d]|[\w\d][\w\d\-]*[\w\d])\.)*((\w|\w[\w\d\-]*[\w\d]))*(\:\d+)+?)(\/[\w\;\:\@\&\=]*[\/[\w\;\:\@\&\=]*]*(\?[\w\;\:\@\&\=]*)?)))$/m';
$str = 'www.google.gmail.com:32/fsd?adsf=asdf
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);