$re = '/((?:(?=^\S{8,}$)(?:(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[^A-Za-z0-9])(?=\S*[a-z])|(?=\S*[^A-Za-z0-9])(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[A-Z])(?=\S*[^A-Za-z0-9]))^\S*){8,})/';
$str = 'aaaaa8A?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);