import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?=^\\S{8,}$)(?:(?=\\S*\\d)(?=\\S*[A-Z])(?=\\S*[a-z])|(?=\\S*\\d)(?=\\S*[^A-Za-z0-9])(?=\\S*[a-z])|(?=\\S*[^A-Za-z0-9])(?=\\S*[A-Z])(?=\\S*[a-z])|(?=\\S*\\d)(?=\\S*[A-Z])(?=\\S*[^A-Za-z0-9]))^\\S*){8,})";
final String string = "aaaaa8A?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}