const regex = /((?:(?=^\S{8,}$)(?:(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[^A-Za-z0-9])(?=\S*[a-z])|(?=\S*[^A-Za-z0-9])(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[A-Z])(?=\S*[^A-Za-z0-9]))^\S*){8,})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?=^\\S{8,}$)(?:(?=\\S*\\d)(?=\\S*[A-Z])(?=\\S*[a-z])|(?=\\S*\\d)(?=\\S*[^A-Za-z0-9])(?=\\S*[a-z])|(?=\\S*[^A-Za-z0-9])(?=\\S*[A-Z])(?=\\S*[a-z])|(?=\\S*\\d)(?=\\S*[A-Z])(?=\\S*[^A-Za-z0-9]))^\\S*){8,})', '')
const str = `aaaaa8A?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}