// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)").unwrap();
let string = "12/02/2134
00/02/2134
01/02/2134
31-12-2134
31-12/2134
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}