$re = '/(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)/m';
$str = '12/02/2134
00/02/2134
01/02/2134
31-12-2134
31-12/2134
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);