const regex = /(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<day>0[1-9]|[12]\\d|3[01])(?P<seperator>[\\\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\\d\\d\\d\\d)', 'gm')
const str = `12/02/2134
00/02/2134
01/02/2134
31-12-2134
31-12/2134
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}