// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([+\-*^]\s*[+\-*^]|[xX]\s*[xX])").unwrap();
let string = "5 + 4 * X + X^2 - 2 + X^2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}