$re = '/([+\-*^]\s*[+\-*^]|[xX]\s*[xX])/';
$str = '5 + 4 * X + X^2 - 2 + X^2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);