package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+\-*^]\s*[+\-*^]|[xX]\s*[xX])`)
var str = `5 + 4 * X + X^2 - 2 + X^2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}