$re = '/(?\'content1\'.+)<delay=(?\'delay\'\d*\.?\d*)f>(?\'content2\'.*)/m';
$str = 'first thing<delay=1.4f>second thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);