package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'content1'.+)<delay=(?'delay'\d*\.?\d*)f>(?'content2'.*)`)
var str = `first thing<delay=1.4f>second thing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}