using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'content1'.+)<delay=(?'delay'\d*\.?\d*)f>(?'content2'.*)";
string input = @"first thing<delay=1.4f>second thing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}