re = /(?<!Above) & |(?i)(\s?)f(?:ea)?t(?:(?:\.?|\s)|uring)(?=\s)|\sx\s|_/m
str = 'Selects all variations of Featuring
& unless preceeded by Above &
x
_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end