$re = '/(?<!Above) & |(?i)(\s?)f(?:ea)?t(?:(?:\.?|\s)|uring)(?=\s)|\sx\s|_/m';
$str = 'Selects all variations of Featuring
& unless preceeded by Above &
x
_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);