#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!Above) & |(?i)(\s?)f(?:ea)?t(?:(?:\.?|\s)|uring)(?=\s)|\sx\s|_"
Local $sString = "Selects all variations of Featuring" & @CRLF & _
" & unless preceeded by Above &" & @CRLF & _
" x " & @CRLF & _
" _"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")